M Menu
b 0 Items s

SCannot Connect DCC Controller

The Captain90

128 posts

Have had no trouble until today in getting my DCC controller to activate. When I start the Railmaster program it goes through the normal startup sequence but the DCC controller does not activate but no error massage is shown. The green controller light in the top right of the screen stays greyed out but the program asks if I wish to set points etc and the normal screen is shown but unfortunately the DCC controller remains inactive.

I have tried rebooting the computer, pulling out the USB cord and waiting 5 seconds but to no avail.

Can anyone please offer any suggestions as to what could be wrong.

Many thanks and Happy New Year.

NormanQ4

640 posts

Hi Captain

Since you have been connecting successfully up to now it sounds like you have inadvertently changed something.

Have you checked that you are using the same USB port as before? This is an easy mistake to make.

The port numbers in Railmaster and windows device manager  must correspond.

Murphy's Law: - "Whatever can go wrong, will go wrong." RM Pro with Elink, Win 10

The Captain90

128 posts

Thanks for your prompt reply Norman. Nothing has changed and the USB port is the one always used. The PC I am using is solely used to run the railway.

Anyway, I left it for an hour or so and tried to reconnect and it did so straight away. To see if this was a one off I closed down and restarted a few times and each time it connected fine.

From past experience I have found RM to be very strange and fickle about the way it wants to do things.

Hopefully it continues to connect.

RAF96

10750 posts


Community Moderator

I recently had a ‘fails to connect’ problem with grey icon, etc and it turned out it was the Elite USB comms gone duff. Once I swapped it out for another controller all was fine. Substitution can be an easy way of checking if a controller or cable is at fault, when all has been well previously. Easy if tou have spares lying around but not if you only have the one.

Rob

Halton Brat - Running Win 10, 64-bit - RM (Pro-Pack) with Elite as Controller-A, Select as Walkabout and E-Link as Controller-B - Locos are mostly TTS. http://www.halton96th.org.uk/page21.html

I'd pick up on the substitution them by downloading a free  evaluation of the Bigbear train control software and configure that to work with your Elite etc. on the same com port with baud rate of 115200.  Then you can tell if it's the DCC controller or RailMaster that's not working without having 2 x DCC controllers

software development engineer by day, model engineer by night

Please create an account or login to reply.

Forum Rules

  • The Hornby Forum is intended for discussion of all things model railways. Primarily a place for newcomers to ask questions and seek assistance from like-minded individuals, the Hornby Forum offers a user community for all those interested in railways.
  • Discussion of non-Hornby brands is allowed, however, active promotion or advertising of these brands is not permitted.
  • Please keep in mind that the Hornby Forum is a publicly viewable space and you should never post personal information (including email addresses). 
  • While every effort is made to contact you before any censorship, we reserve the right to amend or remove any content without explanation.
  • All customer service enquiries should be directed to Hornby Customer Services.

Useful Links

Forum Guidelines

Membership Restricted Product