M Menu
b 0 Items s

SAny ideas please? Straight to max speed

traincliff

160 posts

Could anyone give me a clue what might be happening please? I have today installed TTS chip in Class 66 Evening Star and set it up using Railmaster and e-Link. Ran through most of sound functions and saved, 4 figure address, used recommended 10mph and 60mph shunting and cruise speeds. Problem is now that if I select shunt or cruise the loco goes to maximum speed and can only be brought down by selecting STOP. I am currently connected to Hornby Rolling Road. All my other locos are functioning normally. Have tried rebooting Railmaster and e-Link to no avail.

I have been able to run Evening Star on my layout using just Elite and all functions work and loco is fully controllable. 

Back at the rolling road with no loco on rollers if I select Evening Star and select shunt or cruise the indication goes straight to maximum. So in my view loco and chip are ok. So problem must be in e-Link or Railmaster but HOW can I sort it out guys?

Thanks for reading and hope to get an idea please.

Cliff

Never did see "Black Watch" or "The Green Howards"

Chrissaf

11838 posts


Community Moderator

This is a commonly raised issue and seems to be a new BUG in RailMaster introduced from about version 1.70. The only documented solution found so far is to completely remove your affected loco from the RailMaster loco roster and re-configure it again from scratch. You may have to do this more than once. So far, this fix has solved every instance of this issue that has been raised.

 

If you haven't yet installed version 1.73 from the download link at the top of the RailMaster forum section [i.e if you are still using version 1.72 or below] then I also suggest that you manually upgrade to version 1.73 after you have removed the affected loco from the roster and before you re-configure it again from scratch. So that you are re-configuring the loco again on top of an updated RM version.

Chris........ Making the wood in the trees visible.

traincliff

160 posts

Chrissaf thank you so much for that - I thought I was going mad asI could not find anything I had done wrong. As far as I remember I upgraded to latest version a couple of weeks ago so can't really follow that part of your advice. I added 3 other locos over last 2 weeks so will delete the Evening Star Class 66 from system and try again with fingers crossed. You have suggested reconfiguring but I don't think you mean to reset decoder as that part seems fine. Wow! Thanks again I will update you when I have tried again - probably tomorrow.

Never did see "Black Watch" or "The Green Howards"

Chrissaf

11838 posts


Community Moderator

In the context of my reply .... re-configuring means re-adding the loco to the roster.

 

Just to be absolutely sure you have 1.73 installed. Look to the little yellow boxes to the left of the on-screen RailMaster clock. One of the little yellow boxes should say 1.73

Chris........ Making the wood in the trees visible.

RAF96

13580 posts


Community Moderator

Most things have been tried already as Chris points out, but I am clutching at straws before you re-roster the loco.

 

You could try selecting Scale Speed either on or off as applicable then save and restart RM. Scale speed seems to be troublesome.

 

Have you tried amending the shunt and cruise speeds manually away from default for that loco as it may be when HRMS added the loco to the database there was some bad data fed in. Again save and restart RM to reload the data.

 

In any case it is worth reporting the problem to HRMS using the inbuilt system.

Halton Brat - Running Win 10, 64-bit - RM (Pro-Pack) with Elite as Controller-A, Select as Walkabout and E-Link as Controller-B - Locos are mostly TTS. http://www.halton96th.org.uk/robs_rails.html

traincliff

160 posts

Thanks guys as always. I have not had chance to progress further yet but will report back when I can.

Never did see "Black Watch" or "The Green Howards"

traincliff

160 posts

Well I am delighted to report that after a few suggested checks I deleted 66779 Evening Star, from my roster and reloaded it. This time I noticed some small green letters reading max 75 where yesterday it said max 1. Everything is fine and works exactly as it should. Heartfelt thanks once again to this forum especially Chrissaf and RAF96.

Just a further point I had bought a few additional speakers in case I wanted to change from the Hornby one. Certainly with the Class 66 TTS the supplied one seems fine. I have still got Captain Tom to do but first now I am going to fit a J36 decoder to my J15. Having tried the decoder on my newly acquired tester I don't think I will know the difference!

Cheers everybody!

 Cliff

Never did see "Black Watch" or "The Green Howards"

Chrissaf

11838 posts


Community Moderator

Heartfelt thanks once again to this forum especially Chrissaf and RAF96.

 

Another 'hole in one' with my targeted RM solutions. Glad to have been of service.

Chris........ Making the wood in the trees visible.

Please create an account or login to reply.

Forum Rules

  • The Hornby Forum is intended for discussion of all things model railways. Primarily a place for newcomers to ask questions and seek assistance from like-minded individuals, the Hornby Forum offers a user community for all those interested in railways.
  • Discussion of non-Hornby brands is allowed, however, active promotion or advertising of these brands is not permitted.
  • Please keep in mind that the Hornby Forum is a publicly viewable space and you should never post personal information (including email addresses). 
  • While every effort is made to contact you before any censorship, we reserve the right to amend or remove any content without explanation.
  • All customer service enquiries should be directed to Hornby Customer Services.

Useful Links

Forum Guidelines

This site uses cookies to provide users with the best experience possible, to find out more about them or how to remove cookies from your browser please view our Privacy Policy Or accept cookies to continue to use the website.
Membership Restricted Product